summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-16 08:06:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-16 14:23:01 +0000
commitc68e2aedd801ddefadaec885d83f63e3b2418b51 (patch)
tree352bb1d45aeced2ee2f9e2108456cd2852be8d88 /dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild
parentdev-python/psutil: Bump (diff)
downloadgentoo-c68e2aedd801ddefadaec885d83f63e3b2418b51.tar.gz
gentoo-c68e2aedd801ddefadaec885d83f63e3b2418b51.tar.bz2
gentoo-c68e2aedd801ddefadaec885d83f63e3b2418b51.zip
dev-python/pytest-xprocess: Bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild
new file mode 100644
index 000000000000..66ed6727f6c9
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.12.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ || (
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-python/pytest-2.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ PYTEST_PLUGINS="pytest_xprocess" py.test -v -v || die
+}