summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-28 22:00:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-28 22:50:27 +0100
commitd22cedb2fad2f5c31c7916171f88c9b71231cb16 (patch)
tree01da0495f4e761162f705b2bd8f46f3dda00a332 /dev-python/pytest/pytest-6.2.5-r2.ebuild
parentdev-python/pytest: Backport py3.10 test fixes (diff)
downloadgentoo-d22cedb2fad2f5c31c7916171f88c9b71231cb16.tar.gz
gentoo-d22cedb2fad2f5c31c7916171f88c9b71231cb16.tar.bz2
gentoo-d22cedb2fad2f5c31c7916171f88c9b71231cb16.zip
dev-python/pytest: Disable plugin autoload for reliable testing
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest/pytest-6.2.5-r2.ebuild')
-rw-r--r--dev-python/pytest/pytest-6.2.5-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pytest/pytest-6.2.5-r2.ebuild b/dev-python/pytest/pytest-6.2.5-r2.ebuild
index e1ab42664254..4558e9276b96 100644
--- a/dev-python/pytest/pytest-6.2.5-r2.ebuild
+++ b/dev-python/pytest/pytest-6.2.5-r2.ebuild
@@ -53,7 +53,9 @@ src_test() {
python_test() {
distutils_install_for_testing --via-root
- "${EPYTHON}" -m pytest -vv --lsof -rfsxX -p no:pkgcore -p no:flaky \
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX -p xdist \
-n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
die "Tests failed with ${EPYTHON}"
}