summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-22 07:02:04 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-22 07:35:49 +0100
commit46126a9035488d5b9edbc48a22c1bd51cd72c7af (patch)
tree0396b6f682fdaeefa8d0265c0f3baaa235007cb9 /dev-python/python-dbusmock
parentgnome-extra/gnome-characters: Version bump to 42.0 (diff)
downloadgentoo-46126a9035488d5b9edbc48a22c1bd51cd72c7af.tar.gz
gentoo-46126a9035488d5b9edbc48a22c1bd51cd72c7af.tar.bz2
gentoo-46126a9035488d5b9edbc48a22c1bd51cd72c7af.zip
dev-python/python-dbusmock: Bump to 0.27.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest1
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.27.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index d36ecacb5a0b..bb8c17b5ee23 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,2 +1,3 @@
DIST python-dbusmock-0.25.0.tar.gz 86674 BLAKE2B 9a9f5aefece0f48725f8a453d298fde78e86c86901f5dd3c67032be41cbc52753b8b0da8e8ba3845772e68ba6dcf0938af405f961fc5425808017dd8b30e1419 SHA512 5d7c2f4ea75c7a0f2c6bf63b673c180f3a468239082e0248778441d8f07b78fa3786c1d37498f758954a4727bdb24dc83ffc0671bfc4b2956402aee52c363045
DIST python-dbusmock-0.26.1.tar.gz 87707 BLAKE2B 9f4761ab5f227e78dd5343f3ddd4b83d0494e77d3b381f719890447998baab8096b3bf817259b080dda78619f8407ad532044cb60aaf7a5280459f423754df0f SHA512 dcb46f6dbd17471e2135c0d8fb63cbaecbc9445ae7bf74691abb03b93d5283ab41ea71071ece03870aaac19eaedd546f01c0839116421047f1ac77619f2c73f3
+DIST python-dbusmock-0.27.0.tar.gz 89469 BLAKE2B b6fcdb5ded2b4f50d4c3edafecf028df57c3aae6e2a1e87d78c41f879f495d06ab097be0996b7b1781aebd4235a5ce7c6b58f48f5c74e2d4c2b49a3439ce9cae SHA512 4f3a7326b27d7b86d9a77019c419209077021a88994b8e5ae302686fcaa8b7c7736644ab26d9e3b5a2157634eb56a0b2dbe304a092d93104c94a13a43d53b5a1
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.27.0.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.27.0.ebuild
new file mode 100644
index 000000000000..4b29c538cdd6
--- /dev/null
+++ b/dev-python/python-dbusmock/python-dbusmock-0.27.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="
+ https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # needed for unittest discovery
+ > tests/__init__.py || die
+ # linter tests, fragile to newer linter versions
+ rm tests/test_code.py || die
+
+ distutils-r1_src_prepare
+}