summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-18 22:27:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-18 22:40:30 +0200
commit61b0e2d15f29af35bd16ad5c6553c982a0930e05 (patch)
treed05b4b89463965419d2cce104584e536e18127b7 /dev-python/python-debian
parentdev-python/tikzplotlib: Bump to 0.9.15 (diff)
downloadgentoo-61b0e2d15f29af35bd16ad5c6553c982a0930e05.tar.gz
gentoo-61b0e2d15f29af35bd16ad5c6553c982a0930e05.tar.bz2
gentoo-61b0e2d15f29af35bd16ad5c6553c982a0930e05.zip
dev-python/python-debian: Bump to 0.1.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.42.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index d01aef71f708..7114386ff375 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1 +1,2 @@
DIST python-debian_0.1.40.tar.xz 319952 BLAKE2B 4d5c2d3202ef09fc8eba4e0c4f9a5861d0662f288768cb9026e1ab43309a57fb21c0b8e87734c9310f39646e071947b31b17bd48b71510e7d783af9f337c3ed1 SHA512 73ed735a3c7bb43208aa26ea9fd64fc658e111dc201ae8c1947a4e5835ebd675e37b78d2895d72bd5ed2b6afa491e77b50bd5f10d62ea8299fbdda6c0b9e5095
+DIST python-debian_0.1.42.tar.xz 173928 BLAKE2B 615be084cba8ff11eaaefc1b40335b73a16604b864600dbeb717ba65ee94f1d3a62f845a59c3db5b915346de4211fdde811593db989b143f4d60e7b425b98d2d SHA512 923831077d0a42dafd22277579e714af33b99612e5282f5d95bc884b2faec05321f8caaad20b72b25ce88d8c2449a6a23913c5377ed0bdc30d4ef87e39341ff7
diff --git a/dev-python/python-debian/python-debian-0.1.42.ebuild b/dev-python/python-debian/python-debian-0.1.42.ebuild
new file mode 100644
index 000000000000..c237932970eb
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.42.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2011-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://salsa.debian.org/python-debian-team/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( app-arch/dpkg )
+"
+
+distutils_enable_tests unittest
+
+python_compile_all() {
+ ${EPYTHON} lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}