summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-07-14 13:13:16 -0500
committerBen Kohler <bkohler@gentoo.org>2021-07-14 13:22:25 -0500
commitbb0d8b31cebd52759cc8e06869c615340139926e (patch)
tree83b3f7812d422b8dec9feb11d6d4e3aaa85b1af3 /dev-python/python-keyutils
parentdev-libs/starpu-1.2.6-r1: change the subslot (diff)
downloadgentoo-bb0d8b31cebd52759cc8e06869c615340139926e.tar.gz
gentoo-bb0d8b31cebd52759cc8e06869c615340139926e.tar.bz2
gentoo-bb0d8b31cebd52759cc8e06869c615340139926e.zip
dev-python/python-keyutils: new package needed for udiskie tests
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'dev-python/python-keyutils')
-rw-r--r--dev-python/python-keyutils/Manifest1
-rw-r--r--dev-python/python-keyutils/metadata.xml8
-rw-r--r--dev-python/python-keyutils/python-keyutils-0.6.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-keyutils/Manifest b/dev-python/python-keyutils/Manifest
new file mode 100644
index 000000000000..db74414ead22
--- /dev/null
+++ b/dev-python/python-keyutils/Manifest
@@ -0,0 +1 @@
+DIST python-keyutils-0.6.tar.gz 45427 BLAKE2B b62a1194bad87fe42c658c0603ff236e8e5594e8d19dbf8b29bac5b2ef5b3c6a6d19eae3d529c9408e06802c883fad365d41d27c656776a4994b58a43b8bf1fc SHA512 e282d553a644d9b38c6256e027ee553a123bf21e4222491e22699ca5bc5041dedc4e9a9a8c1bafa44985f3b1d5fafd85ded9ed5332b6d94d6c62f3fa6bcb6d0d
diff --git a/dev-python/python-keyutils/metadata.xml b/dev-python/python-keyutils/metadata.xml
new file mode 100644
index 000000000000..c67d4dcaca5b
--- /dev/null
+++ b/dev-python/python-keyutils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-keyutils/python-keyutils-0.6.ebuild b/dev-python/python-keyutils/python-keyutils-0.6.ebuild
new file mode 100644
index 000000000000..3934da52194c
--- /dev/null
+++ b/dev-python/python-keyutils/python-keyutils-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit distutils-r1
+
+DESCRIPTION="A set of python bindings for keyutils"
+HOMEPAGE="https://github.com/sassoftware/python-keyutils/"
+SRC_URI="https://github.com/sassoftware/python-keyutils/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/keyutils"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ sed -i -e '/pytest-runner/d' setup.py || die
+}
+
+python_test() {
+ ln -s "${S}"/test "${BUILD_DIR}"/test || die
+ cd "${BUILD_DIR}" || die
+ distutils-r1_python_test
+}