summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-22 06:13:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-22 07:53:30 +0200
commita33b5428d1ce6d50c964b899f7c8e20c36b370e3 (patch)
tree67d42b974d32cab95dd88dd2f965e03f3e767c94 /dev-python/python-lsp-black
parentdev-python/fastjsonschema: Bump to 2.17.0 (diff)
downloadgentoo-a33b5428d1ce6d50c964b899f7c8e20c36b370e3.tar.gz
gentoo-a33b5428d1ce6d50c964b899f7c8e20c36b370e3.tar.bz2
gentoo-a33b5428d1ce6d50c964b899f7c8e20c36b370e3.zip
dev-python/python-lsp-black: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest1
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 1764ee4a7edc..76bec82b40e6 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1 +1,2 @@
DIST python-lsp-black-1.2.1.gh.tar.gz 9355 BLAKE2B f9c70ff07d9dfa31e3af919143deb8a49f43269469e8c64525f514624f4db67636da8254dae5274685ba2d883c8ddfd6dd9cb99981a337d7837d4007f15af11c SHA512 289b8f3642ed806409671d25e32997fb473720d0abd642c58c07d8c894831fa00f56dbc39e7d0fc8d98cad7de9f95ebdb6a0f637b8b4bbcc2a0716690feb647e
+DIST python-lsp-black-1.3.0.gh.tar.gz 9781 BLAKE2B d079d7a95dff682b86df23825796d2fa6e89d1aa3e66da1452e576fd1e96a4c298da181f53840fe5fcdcbbc8a0ca55aa53cbc4885a0178b6402365ef41a239be SHA512 9e3d081ac022854626c120128949ab5e58c44f9e76ddd566e3b80a697fbc02a96f62994f43195b02f899e770768d55d223984267133eedd6f642b70560d46c09
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild
new file mode 100644
index 000000000000..9274bf63b458
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-22.3.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest