summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <nils.freydank@posteo.de>2020-07-06 14:23:19 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-15 11:06:35 +0300
commit3ffa1a428ba6935da4fb057fb52549cd44c9b049 (patch)
tree394050acc39bf70f83668929c6a0f42bcf72688d /dev-python/python-markdown-math
parentdev-python/markdown: Support python3_9 (diff)
downloadgentoo-3ffa1a428ba6935da4fb057fb52549cd44c9b049.tar.gz
gentoo-3ffa1a428ba6935da4fb057fb52549cd44c9b049.tar.bz2
gentoo-3ffa1a428ba6935da4fb057fb52549cd44c9b049.zip
dev-python/python-markdown-math: Bump to 0.7 and support python3_9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/python-markdown-math')
-rw-r--r--dev-python/python-markdown-math/Manifest1
-rw-r--r--dev-python/python-markdown-math/python-markdown-math-0.7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-markdown-math/Manifest b/dev-python/python-markdown-math/Manifest
index 81437ba1b841..f274f179434e 100644
--- a/dev-python/python-markdown-math/Manifest
+++ b/dev-python/python-markdown-math/Manifest
@@ -1 +1,2 @@
DIST python-markdown-math-0.6.tar.gz 6406 BLAKE2B 43172ba4b36b697f196bd569c93d56d1a3a05aaa306b1f149f3b70372e624e35fc0d3f3ea3c58c6b86e00c68408a5ebfe9fcc6562fe5065c7f8a7aa8683ee084 SHA512 af5773dc5b6d8968d811487a86fd027042d381b8b5b37683b519f03f21097bafd3d174881d8201cb6524e0975cd6868781e116cec6406fa20ffd3c6b9f9d4e87
+DIST python-markdown-math-0.7.tar.gz 8320 BLAKE2B b402a6c1c3ef93f8716b88c0ba356109e6b483ce26b4a7923c16642a7a7fe69b25ee00e4f537d26b6fa743e81fef05871c447f9e5d3a986ff52bf7095bcdd436 SHA512 05bfff71c758785591c388a95b176205a8707428cbda91734c4f1b5d39cd030d9106782e92aca8f1de18be227b1489ad2cb09981b4455ba1d1177974cd0cbecd
diff --git a/dev-python/python-markdown-math/python-markdown-math-0.7.ebuild b/dev-python/python-markdown-math/python-markdown-math-0.7.ebuild
new file mode 100644
index 000000000000..be5802d79954
--- /dev/null
+++ b/dev-python/python-markdown-math/python-markdown-math-0.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+
+DESCRIPTION="Math extension for Python-Markdown"
+HOMEPAGE="https://github.com/mitya57/python-markdown-math"
+
+if [[ ${PV} == **9999 ]]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mitya57/python-markdown-math.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests for python2.7 ran fine even with dev-python/markdown-2.6.5,
+# but only python3.7 is supported with $PV >= 3.x.
+DEPEND="
+ >=dev-python/markdown-3.0.1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+python_test() {
+ esetup.py test
+}