summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-18 13:25:16 +0200
committerBen Kohler <bkohler@gentoo.org>2019-12-05 12:44:56 -0600
commitdaa3d66ca418d487745a50930ae4c3d8a186eedb (patch)
treed39edc6c873f546e5b002534cede02efea910e55 /dev-python/python-prctl/python-prctl-1.7.ebuild
parentgames-board/gnubg: 1.06.002 bump (diff)
downloadgentoo-daa3d66ca418d487745a50930ae4c3d8a186eedb.tar.gz
gentoo-daa3d66ca418d487745a50930ae4c3d8a186eedb.tar.bz2
gentoo-daa3d66ca418d487745a50930ae4c3d8a186eedb.zip
dev-python/python-prctl: bump version 1.7, EAPI 7
Closes: https://bugs.gentoo.org/669074 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'dev-python/python-prctl/python-prctl-1.7.ebuild')
-rw-r--r--dev-python/python-prctl/python-prctl-1.7.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-prctl/python-prctl-1.7.ebuild b/dev-python/python-prctl/python-prctl-1.7.ebuild
new file mode 100644
index 000000000000..47d8ce68b2aa
--- /dev/null
+++ b/dev-python/python-prctl/python-prctl-1.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/libcap"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"