summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-18 08:21:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-18 08:33:52 +0100
commitebebeee1771d65f7fee1b51c36abcac107c26884 (patch)
treed0a65c1aae6e3f02ebbbbb080f785754236dddb3 /dev-python/python-redmine
parentdev-python/dulwich: Bump to 0.21.1 (diff)
downloadgentoo-ebebeee1771d65f7fee1b51c36abcac107c26884.tar.gz
gentoo-ebebeee1771d65f7fee1b51c36abcac107c26884.tar.bz2
gentoo-ebebeee1771d65f7fee1b51c36abcac107c26884.zip
dev-python/python-redmine: Bump to 2.4.0
Closes: https://bugs.gentoo.org/888263 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-redmine')
-rw-r--r--dev-python/python-redmine/Manifest1
-rw-r--r--dev-python/python-redmine/python-redmine-2.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-redmine/Manifest b/dev-python/python-redmine/Manifest
index 990b7f65b7c7..23809691ce5e 100644
--- a/dev-python/python-redmine/Manifest
+++ b/dev-python/python-redmine/Manifest
@@ -1 +1,2 @@
DIST python-redmine-2.3.0.tar.gz 67915 BLAKE2B ad31d63ec5bebd33ff436f04c40fd49e35a79751c353ba1e343bbb03048c2d1662ec8ffea5819561b675e366f8cbad48a0e0a0a59dcaa563a90301ad4f1eb1cf SHA512 a317743a561cde65c17356a317d3aed082149d648aaa7487858c8533ceb286d08b6610d742321f6593fef8b61b1a4526963ddffc4ab180a83795d66773154b70
+DIST python-redmine-2.4.0.tar.gz 67730 BLAKE2B 22c74ad194af9b56affab39de38b13a8f5a46e79b8ea8d9f9f47eb12c4ad4c91156db9ef0e8dfd013602b8cc06e0636a724ae34969f385dc9f8ffc63514ccc63 SHA512 afb03ca8a3bdacace3c12b7295ba08953ab2040971b57988deb9955df24e5ac1782a9b3fbf0f5070eb22c640e88f489cda12cdec38449f9e3bcf7189dc422642
diff --git a/dev-python/python-redmine/python-redmine-2.4.0.ebuild b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
new file mode 100644
index 000000000000..b2161c074c88
--- /dev/null
+++ b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the Redmine REST API"
+HOMEPAGE="
+ https://github.com/maxtepkeev/python-redmine/
+ https://pypi.org/project/python-redmine/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.28.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}