summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-22 21:49:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-22 21:55:23 +0100
commit76342f376016b616ec97056804f736d6696bcde7 (patch)
tree4bf6ba81ee9e55abc098aa8a857f7243744cf158 /dev-python/python-socks/python-socks-2.0.3.ebuild
parentdev-python/cftime: Bump to 1.5.2 (diff)
downloadgentoo-76342f376016b616ec97056804f736d6696bcde7.tar.gz
gentoo-76342f376016b616ec97056804f736d6696bcde7.tar.bz2
gentoo-76342f376016b616ec97056804f736d6696bcde7.zip
dev-python/python-socks: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks/python-socks-2.0.3.ebuild')
-rw-r--r--dev-python/python-socks/python-socks-2.0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-socks/python-socks-2.0.3.ebuild b/dev-python/python-socks/python-socks-2.0.3.ebuild
new file mode 100644
index 000000000000..8a16ad7e8e0f
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest