summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-18 18:38:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-18 18:41:09 +0100
commita7c91991b6401357fc5cb09fa3408480c8fdd7e6 (patch)
tree9202dac9e3041001fbaa70943ca7a4be69d1afc3 /dev-python/python-systemd
parentdev-libs/libpwquality: add 1.4.5 (diff)
downloadgentoo-a7c91991b6401357fc5cb09fa3408480c8fdd7e6.tar.gz
gentoo-a7c91991b6401357fc5cb09fa3408480c8fdd7e6.tar.bz2
gentoo-a7c91991b6401357fc5cb09fa3408480c8fdd7e6.zip
dev-python/python-systemd: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-systemd')
-rw-r--r--dev-python/python-systemd/Manifest1
-rw-r--r--dev-python/python-systemd/files/python-systemd-234-fix-py3.10.patch46
-rw-r--r--dev-python/python-systemd/python-systemd-234-r2.ebuild39
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/python-systemd/Manifest b/dev-python/python-systemd/Manifest
index 98ada322756b..995668ddefba 100644
--- a/dev-python/python-systemd/Manifest
+++ b/dev-python/python-systemd/Manifest
@@ -1,2 +1 @@
-DIST python-systemd-234.tar.gz 53900 BLAKE2B 2658ee7083036ed8259e5f4ad0714ea15227ee836ad34c7fbbdb55dd9df48751b8d9998350d789b4f47e78fe7b4a7134e12d637e5a6ebeb29a0b31e5a4575d91 SHA512 164e34ba46827711e9c6ff9ed58b2706d9a22abfc7001de030ed7d463d8ddf783eb5fee93b207c29950a3c566018cc3f1a21a549421cf3e05c1287b433367eb2
DIST python-systemd-235.gh.tar.gz 59858 BLAKE2B 8dbf112773dce4dfe9fb2b0e660a349481fa29c9532c5aa2d125e5bfc255b2408f63b5bd873b6fee9ebbad775ecfaf32497593b17052189797403fa31b05fd6f SHA512 f1286a477200cc7b4d2c44b43452da576e8e660925711466659795775bcee44796688e1ede6cc22e61cb5b03e631c396d22f9a133327ae1147506bce09bab47f
diff --git a/dev-python/python-systemd/files/python-systemd-234-fix-py3.10.patch b/dev-python/python-systemd/files/python-systemd-234-fix-py3.10.patch
deleted file mode 100644
index 52045b4475e1..000000000000
--- a/dev-python/python-systemd/files/python-systemd-234-fix-py3.10.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From c71bbac357f0ac722e1bcb2edfa925b68cca23c9 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
-Date: Thu, 12 Nov 2020 16:55:56 +0100
-Subject: [PATCH] reader: make PY_SSIZE_T_CLEAN
-
----
- systemd/_reader.c | 15 +++++++++++++--
- 1 file changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/systemd/_reader.c b/systemd/_reader.c
-index 8de7f6a..3b6a4d0 100644
---- a/systemd/_reader.c
-+++ b/systemd/_reader.c
-@@ -18,7 +18,12 @@
- along with python-systemd; If not, see <http://www.gnu.org/licenses/>.
- ***/
-
-+#define PY_SSIZE_T_CLEAN
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Wredundant-decls"
- #include <Python.h>
-+#pragma GCC diagnostic pop
-+
- #include <structmember.h>
- #include <datetime.h>
- #include <time.h>
-@@ -710,11 +715,17 @@ PyDoc_STRVAR(Reader_add_match__doc__,
- "Match is a string of the form \"FIELD=value\".");
- static PyObject* Reader_add_match(Reader *self, PyObject *args, PyObject *keywds) {
- char *match;
-- int match_len, r;
-+ Py_ssize_t match_len;
-+ int r;
- if (!PyArg_ParseTuple(args, "s#:add_match", &match, &match_len))
- return NULL;
-
-- r = sd_journal_add_match(self->j, match, match_len);
-+ if (match_len > INT_MAX) {
-+ set_error(-ENOBUFS, NULL, NULL);
-+ return NULL;
-+ }
-+
-+ r = sd_journal_add_match(self->j, match, (int) match_len);
- if (set_error(r, NULL, "Invalid match") < 0)
- return NULL;
-
diff --git a/dev-python/python-systemd/python-systemd-234-r2.ebuild b/dev-python/python-systemd/python-systemd-234-r2.ebuild
deleted file mode 100644
index ec89a20eafc7..000000000000
--- a/dev-python/python-systemd/python-systemd-234-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2015-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for native access to the systemd facilities"
-HOMEPAGE="https://github.com/systemd/python-systemd"
-SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 ~s390 sparc x86"
-
-DEPEND="sys-apps/systemd:0="
-RDEPEND="${DEPEND}
- !sys-apps/systemd[python(-)]
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-py3.10.patch
-)
-
-distutils_enable_tests pytest
-
-python_compile() {
- # https://bugs.gentoo.org/690316
- distutils-r1_python_compile -j1
-}
-
-python_test() {
- unset NOTIFY_SOCKET
- cd "${T}" || die
- epytest --pyargs systemd -o cache_dir="${T}"
-}