summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-14 20:01:54 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-14 20:28:24 +0200
commit613e139267f64c61a08b2b80301293cec44138c7 (patch)
tree8817dcd54e93e37f8e3c38478270f0cce3af9f8e /dev-python/python-utils
parentdev-embedded/u-boot-tools: add 2022.01 (diff)
downloadgentoo-613e139267f64c61a08b2b80301293cec44138c7.tar.gz
gentoo-613e139267f64c61a08b2b80301293cec44138c7.tar.bz2
gentoo-613e139267f64c61a08b2b80301293cec44138c7.zip
dev-python/python-utils: add 3.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index b27835398dd0..35fb3cc9ad9e 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -4,3 +4,4 @@ DIST python-utils-2.6.3.tar.gz 14914 BLAKE2B 6df19348feba000dccc516704db38af2996
DIST python-utils-2.7.0.tar.gz 27743 BLAKE2B 5cd0671ad1e003932aed0bf0b69326d907013d3f739e833f218600ee056d76bc87dd2a424f5459654de30dacc3378c14f10af1664344ac66813410d261718c61 SHA512 3401c9ad2e4933d0d40d4bc90f1dbe212e672289e7239a4a46d79a04e80f85bb0def67324f0184ca397ec3708cb935839ffe922a202de9c911198ea86d88e2c5
DIST python-utils-2.7.1.tar.gz 28997 BLAKE2B 3da11dcb297cace3c2c48ae91e6011be2f484a83f264be375437775eb99d9bafe703626ab0d2217da79ec096f90648d387ec7b41611e915ef33fce152553a18c SHA512 9f74a33089886dcd28dfd45602c53a7c6cfc90b151a053dd7e49a5fd502479e889d08bd8b10fdd2ec3bc26e334ae66238740ff59291f4ac95fb486b64f925d4a
DIST python-utils-3.0.0.tar.gz 23243 BLAKE2B 640ebc1b3e59a30be5a5c40291d121919b9f90a71476acf66741cb4b8af691c50c3826d9e8e6b30464f2be8e5ba0ac4683f79962c8833073b8a43a108ead281d SHA512 b03f97b66b71af8eb023ecfa1b671f2d566d139464f63cd512b129a5830651172843285fe7ef028047ca03f345221f5208eac8e1647361f173f1c7b3aed866a6
+DIST python-utils-3.1.0.tar.gz 24251 BLAKE2B c00f4c45480f0948cddfa65d4f1ce17ac6831e29b24913d225544619ebedaca67c0f143b55698f8e2edd658e5f90ac39e005a5c29e09d75b5643f79992ba878a SHA512 e22ea0dc7aa0e6c5b45c55843011971c5075639424d38a712703b0d5ef8af32e3661d39af63b6015c4edfe11fca7a256f4f02c3705e1724fe8b9015931d85cbf
diff --git a/dev-python/python-utils/python-utils-3.1.0.ebuild b/dev-python/python-utils/python-utils-3.1.0.ebuild
new file mode 100644
index 000000000000..abb04012919a
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3)
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}