summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-28 11:16:39 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-28 11:16:39 -0800
commita13338c8b4cf10b4c9a76a72d66d47b971d881c2 (patch)
tree555de0ae2d25979863fd8a0a0c70d4fa3987153c /dev-python/python3-saml
parentsys-process/bpytop-1.0.61: Version bump (bug #766824) (diff)
downloadgentoo-a13338c8b4cf10b4c9a76a72d66d47b971d881c2.tar.gz
gentoo-a13338c8b4cf10b4c9a76a72d66d47b971d881c2.tar.bz2
gentoo-a13338c8b4cf10b4c9a76a72d66d47b971d881c2.zip
dev-python/python3-saml-1.10.1: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest1
-rw-r--r--dev-python/python3-saml/python3-saml-1.10.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
index 69a6b153fe44..59e40f53dda3 100644
--- a/dev-python/python3-saml/Manifest
+++ b/dev-python/python3-saml/Manifest
@@ -1,2 +1,3 @@
DIST python3-saml-1.10.0.tar.gz 503005 BLAKE2B 88be9b00082d00c86081432dd6789c0f040e8e210d3d1de218f8bf7a41cf32acce6aa90f92b6e083142a2a5c8f820eb9f8b6e880e742400b8bb83e7eb28db392 SHA512 82d15ef4315d25b38506177cbb4ef095a0546705035491847597b353486e119026c700f5d4d22764c93646f645e13d93d75bd3541c2c5b31343bcee35a42ead3
+DIST python3-saml-1.10.1.tar.gz 503178 BLAKE2B 6c87f26db03799ee92211baf1216751c293ae6182d8f8abb094fcc47c2c28ca7be933b64b0dc3cbd52ea55a0cd19c4fc96a71bb89839d41fdd3eb3daee21d293 SHA512 64bd3fc11749ef8340fa59788277e5213edec6d93f7924e412e517846623dce88b97c407ca7ae0d58172cc78a8b713c2916fe5c29df3419fa10f34b84bdb549c
DIST python3-saml-1.9.0.tar.gz 497106 BLAKE2B c3b282be835dcd0590125563ed0380bbb5d486aeffd60fa0d6a1e7d22b25ffaa03a1bea555520b1465b27b352df0936d21b919ce73a3671d63f07a52b3efdb37 SHA512 a5171258b917c02f10a0c420a19fe6829a034df1dfd87135351b9c187314dca2f973012f49056f391444aba76306adfd48cd77a859274d5cbd2a8c23a00af78d
diff --git a/dev-python/python3-saml/python3-saml-1.10.1.ebuild b/dev-python/python3-saml/python3-saml-1.10.1.ebuild
new file mode 100644
index 000000000000..ca0bb11a6cd7
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.10.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+ https://pypi.org/project/python3-saml/"
+SRC_URI="https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/python-xmlsec-1.0.5[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}