summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 11:44:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:50 +0100
commitfb1d5acebd21da9856b796632880466163197dfe (patch)
tree7de2e89c492b2c5fd0fc64a2f38b5672d890c920 /dev-python/python_orocos_kdl/files
parentdev-python/python_orocos_kdl: Install package.xml in our custom gentoo path f... (diff)
downloadgentoo-fb1d5acebd21da9856b796632880466163197dfe.tar.gz
gentoo-fb1d5acebd21da9856b796632880466163197dfe.tar.bz2
gentoo-fb1d5acebd21da9856b796632880466163197dfe.zip
dev-python/python_orocos_kdl: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/python_orocos_kdl/files')
-rw-r--r--dev-python/python_orocos_kdl/files/gentoo.patch12
-rw-r--r--dev-python/python_orocos_kdl/files/py3.patch58
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/python_orocos_kdl/files/gentoo.patch b/dev-python/python_orocos_kdl/files/gentoo.patch
deleted file mode 100644
index 571ee0348249..000000000000
--- a/dev-python/python_orocos_kdl/files/gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: python_orocos_kdl/CMakeLists.txt
-===================================================================
---- python_orocos_kdl.orig/CMakeLists.txt
-+++ python_orocos_kdl/CMakeLists.txt
-@@ -21,4 +21,5 @@ set(SIP_EXTRA_OPTIONS "-o")
- set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/${PYTHON_SITE_PACKAGES})
- add_sip_python_module(PyKDL PyKDL/PyKDL.sip ${orocos_kdl_LIBRARIES})
-
--install(FILES package.xml DESTINATION share/python_orocos_kdl)
-\ No newline at end of file
-+install(FILES package.xml DESTINATION share/python_orocos_kdl)
-+install(FILES package.xml DESTINATION share/ros_packages/python_orocos_kdl)
diff --git a/dev-python/python_orocos_kdl/files/py3.patch b/dev-python/python_orocos_kdl/files/py3.patch
deleted file mode 100644
index dd22f2d41293..000000000000
--- a/dev-python/python_orocos_kdl/files/py3.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Upstream status: Pending.
-https://github.com/orocos/orocos_kinematics_dynamics/pull/44
-
-Index: orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/CMakeLists.txt
-===================================================================
---- orocos_kinematics_dynamics-1.3.0.orig/python_orocos_kdl/CMakeLists.txt
-+++ orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/CMakeLists.txt
-@@ -8,7 +8,7 @@ link_directories(${orocos_kdl_LIBRARY_DI
-
- find_package(PythonInterp REQUIRED)
- find_package(PythonLibs ${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} REQUIRED)
--execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(plat_specific=True, prefix='')" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
-+execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(plat_specific=True, prefix=''))" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
- list(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
- find_package(SIP REQUIRED)
- include(SIPMacros)
-Index: orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/PyKDL/std_string.sip
-===================================================================
---- orocos_kinematics_dynamics-1.3.0.orig/python_orocos_kdl/PyKDL/std_string.sip
-+++ orocos_kinematics_dynamics-1.3.0/python_orocos_kdl/PyKDL/std_string.sip
-@@ -27,7 +27,7 @@
- newstring = PyUnicode_DecodeUTF8(sipCpp->c_str(), sipCpp->length(), NULL);
- if(newstring == NULL) {
- PyErr_Clear();
-- newstring = PyString_FromString(sipCpp->c_str());
-+ newstring = PyUnicode_FromString(sipCpp->c_str());
- }
- return newstring;
- %End
-@@ -38,21 +38,27 @@
- // If argument is a Unicode string, just decode it to UTF-8
- // If argument is a Python string, assume it's UTF-8
- if (sipIsErr == NULL)
-+#if PY_MAJOR_VERSION < 3
- return (PyString_Check(sipPy) || PyUnicode_Check(sipPy));
-+#else
-+ return PyUnicode_Check(sipPy);
-+#endif
- if (sipPy == Py_None) {
- *sipCppPtr = new std::string;
- return 1;
- }
- if (PyUnicode_Check(sipPy)) {
- PyObject* s = PyUnicode_AsEncodedString(sipPy, "UTF-8", "");
-- *sipCppPtr = new std::string(PyString_AS_STRING(s));
-+ *sipCppPtr = new std::string(PyUnicode_AS_DATA(s));
- Py_DECREF(s);
- return 1;
- }
-+#if PY_MAJOR_VERSION < 3
- if (PyString_Check(sipPy)) {
- *sipCppPtr = new std::string(PyString_AS_STRING(sipPy));
- return 1;
- }
-+#endif
-
- return 0;
- %End