summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-05 18:07:27 +0000
committerSam James <sam@gentoo.org>2021-11-05 18:07:27 +0000
commitb16f59f577ac9a61054a3ccf0eb057ca98dc6875 (patch)
tree13a4306ce8111577126fe43f1a08485619552332 /dev-python/pythran
parentdev-python/scipy: Keyword 1.7.1-r1 ia64, #804115 (diff)
downloadgentoo-b16f59f577ac9a61054a3ccf0eb057ca98dc6875.tar.gz
gentoo-b16f59f577ac9a61054a3ccf0eb057ca98dc6875.tar.bz2
gentoo-b16f59f577ac9a61054a3ccf0eb057ca98dc6875.zip
dev-python/pythran: fix tests (drop -Werror)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/files/pythran-0.10.0-tests-werror.patch11
-rw-r--r--dev-python/pythran/pythran-0.10.0.ebuild4
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/pythran/files/pythran-0.10.0-tests-werror.patch b/dev-python/pythran/files/pythran-0.10.0-tests-werror.patch
new file mode 100644
index 000000000000..17c0630a5d1e
--- /dev/null
+++ b/dev-python/pythran/files/pythran-0.10.0-tests-werror.patch
@@ -0,0 +1,11 @@
+--- a/pythran/tests/__init__.py
++++ b/pythran/tests/__init__.py
+@@ -71,7 +71,7 @@ class TestEnv(unittest.TestCase):
+
+ module = pytest.mark.module
+ # default options used for the c++ compiler
+- PYTHRAN_CXX_FLAGS = ['-O0', '-Wall', '-Werror', '-UNDEBUG',
++ PYTHRAN_CXX_FLAGS = ['-O0', '-Wall', '-UNDEBUG',
+ '-Wno-unused-function',
+ '-Wno-int-in-bool-context',
+ '-Wno-unknown-warning-option',
diff --git a/dev-python/pythran/pythran-0.10.0.ebuild b/dev-python/pythran/pythran-0.10.0.ebuild
index 549382ff6f94..ce0bf29dc3f0 100644
--- a/dev-python/pythran/pythran-0.10.0.ebuild
+++ b/dev-python/pythran/pythran-0.10.0.ebuild
@@ -36,6 +36,10 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.0-tests-werror.patch
+)
+
src_prepare() {
sed -i -e '/pytest-runner/d' setup.py || die
distutils-r1_src_prepare