summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-02 00:08:02 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-02 00:08:21 +0100
commit75eec14cda77354d357710efacf66a8d4839e00c (patch)
treed9c6ba7bd099213d90e0c4e14fd2c90ee3aa01fd /dev-python/pyusb/pyusb-1.1.0.ebuild
parentmedia-libs/mesa: Allow building with USE="-X -egl" (diff)
downloadgentoo-75eec14cda77354d357710efacf66a8d4839e00c.tar.gz
gentoo-75eec14cda77354d357710efacf66a8d4839e00c.tar.bz2
gentoo-75eec14cda77354d357710efacf66a8d4839e00c.zip
dev-python/pyusb: bump to 1.1.0
Tests no longer segfault python, supports python3_9, some cosmetics. Pushed with permission from mgorny on behalf of the Python project. Closes: https://bugs.gentoo.org/645254 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pyusb/pyusb-1.1.0.ebuild')
-rw-r--r--dev-python/pyusb/pyusb-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyusb/pyusb-1.1.0.ebuild b/dev-python/pyusb/pyusb-1.1.0.ebuild
new file mode 100644
index 000000000000..f329f17c2418
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+DOCS=( README.rst docs/tutorial.rst )
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}