summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-09 08:41:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-09 09:26:06 +0200
commit72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa (patch)
tree9edfc0204eeecedfe15c019c0f82214e23265712 /dev-python/pyusb/pyusb-1.2.1.ebuild
parentdev-python/cffi: Bump to 1.14.6 (diff)
downloadgentoo-72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa.tar.gz
gentoo-72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa.tar.bz2
gentoo-72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa.zip
dev-python/pyusb: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyusb/pyusb-1.2.1.ebuild')
-rw-r--r--dev-python/pyusb/pyusb-1.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyusb/pyusb-1.2.1.ebuild b/dev-python/pyusb/pyusb-1.2.1.ebuild
new file mode 100644
index 000000000000..24e01cf2f163
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+DOCS=( README.rst docs/tutorial.rst )
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}