summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 06:03:43 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:46 +0000
commitfe27a8ef786d37b1fbfe76fddc1c71d3eacb91ed (patch)
treeeec2fb69f9ee98545c07a882e2ec67f8a4811a5b /dev-python/pyxattr/pyxattr-0.7.2.ebuild
parentdev-python/pyxdg: mark ALLARCHES (diff)
downloadgentoo-fe27a8ef786d37b1fbfe76fddc1c71d3eacb91ed.tar.gz
gentoo-fe27a8ef786d37b1fbfe76fddc1c71d3eacb91ed.tar.bz2
gentoo-fe27a8ef786d37b1fbfe76fddc1c71d3eacb91ed.zip
dev-python/pyxattr: bump to 0.7.2
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyxattr/pyxattr-0.7.2.ebuild')
-rw-r--r--dev-python/pyxattr/pyxattr-0.7.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyxattr/pyxattr-0.7.2.ebuild b/dev-python/pyxattr/pyxattr-0.7.2.ebuild
new file mode 100644
index 000000000000..6202df6da8ee
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="https://pyxattr.k1024.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://pyxattr.k1024.org/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-apps/attr:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/recommonmark
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}