summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-02 19:43:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-02 21:03:29 +0200
commit340db7d8a06cb02fa0ecb39cef6386fac167d196 (patch)
tree1c8bdd7e220dd67298b22c695f58a7383a8dbf77 /dev-python/qtconsole
parentmedia-libs/taglib: add 1.13.1 (diff)
downloadgentoo-340db7d8a06cb02fa0ecb39cef6386fac167d196.tar.gz
gentoo-340db7d8a06cb02fa0ecb39cef6386fac167d196.tar.bz2
gentoo-340db7d8a06cb02fa0ecb39cef6386fac167d196.zip
dev-python/qtconsole: Test against available QtPy backends
Run the test suite against all the backends that are supported by the installed QtPy version rather than incidentally forcing pyside. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.3.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/qtconsole/qtconsole-5.4.3.ebuild b/dev-python/qtconsole/qtconsole-5.4.3.ebuild
index 6ec82c52c0bf..3cd57fe34ba3 100644
--- a/dev-python/qtconsole/qtconsole-5.4.3.ebuild
+++ b/dev-python/qtconsole/qtconsole-5.4.3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 pypi
@@ -31,10 +31,9 @@ RDEPEND="
>=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
>=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
"
-# The test suite tests both against pyqt5 *and* pyside2
BDEPEND="
test? (
- dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
)
"
# required by the tests that are removed:
@@ -51,9 +50,16 @@ distutils_enable_tests pytest
python_test() {
# TODO: these tests require virtx; however, running under virtx
# causes pytest to segv on exit (even though tests pass)
- EPYTEST_IGNORE=(
+ local EPYTEST_IGNORE=(
qtconsole/tests/test_00_console_widget.py
qtconsole/tests/test_jupyter_widget.py
)
- epytest
+ local -x QT_API
+ for QT_API in pyqt5 pyqt6 pyside2 pyside6; do
+ if has_version "dev-python/QtPy[${QT_API}]"; then
+ local -x PYTEST_QT_API=${QT_API}
+ einfo "Testing with ${QT_API}"
+ epytest
+ fi
+ done
}