summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 12:37:36 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 12:38:00 +0100
commitd85169c4e4bf3400c5d2cd2687a0940cb1326152 (patch)
treedf1c023624d8f6bc81884632bedb2238dea09124 /dev-python/redis-py/files
parentdev-python/webob: Version Bump (diff)
downloadgentoo-d85169c4e4bf3400c5d2cd2687a0940cb1326152.tar.gz
gentoo-d85169c4e4bf3400c5d2cd2687a0940cb1326152.tar.bz2
gentoo-d85169c4e4bf3400c5d2cd2687a0940cb1326152.zip
dev-python/redis-py: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/redis-py/files')
-rw-r--r--dev-python/redis-py/files/redis-py-2.10.5-test-backport.patch24
-rw-r--r--dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch19
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/redis-py/files/redis-py-2.10.5-test-backport.patch b/dev-python/redis-py/files/redis-py-2.10.5-test-backport.patch
new file mode 100644
index 000000000000..74d2d14134d5
--- /dev/null
+++ b/dev-python/redis-py/files/redis-py-2.10.5-test-backport.patch
@@ -0,0 +1,24 @@
+From 550eee8106ca5984f104b3a2a79299d9ae0821af Mon Sep 17 00:00:00 2001
+From: Chris Lamb <chris@chris-lamb.co.uk>
+Date: Tue, 18 Aug 2015 13:28:40 +0200
+Subject: [PATCH] Fix tests under Redis 3.x; we can be of an "embedded string"
+ format now.
+
+Signed-off-by: Chris Lamb <chris@chris-lamb.co.uk>
+---
+ tests/test_commands.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_commands.py b/tests/test_commands.py
+index 2e104ed..c0e56b0 100644
+--- a/tests/test_commands.py
++++ b/tests/test_commands.py
+@@ -112,7 +112,7 @@ def test_object(self, r):
+ r['a'] = 'foo'
+ assert isinstance(r.object('refcount', 'a'), int)
+ assert isinstance(r.object('idletime', 'a'), int)
+- assert r.object('encoding', 'a') == b('raw')
++ assert r.object('encoding', 'a') in (b('raw'), b('embstr'))
+ assert r.object('idletime', 'invalid-key') is None
+
+ def test_ping(self, r):
diff --git a/dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch b/dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch
new file mode 100644
index 000000000000..1a807480dfb0
--- /dev/null
+++ b/dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch
@@ -0,0 +1,19 @@
+ setup.py | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index ed8fd5f..ab648a3 100644
+--- a/setup.py
++++ b/setup.py
+@@ -9,11 +9,6 @@ try:
+ from setuptools.command.test import test as TestCommand
+
+ class PyTest(TestCommand):
+- def finalize_options(self):
+- TestCommand.finalize_options(self)
+- self.test_args = []
+- self.test_suite = True
+-
+ def run_tests(self):
+ # import here, because outside the eggs aren't loaded
+ import pytest