summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-10 19:31:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-10 19:45:59 +0200
commit207a4177fac4c95ab303bece3c8a7f080b85d40f (patch)
treeaae0e4fc02c3f1445923f404bea7a0f9c6071ced /dev-python/requests-cache
parentdev-python/cattrs: New dep of dev-python/requests-cache (diff)
downloadgentoo-207a4177fac4c95ab303bece3c8a7f080b85d40f.tar.gz
gentoo-207a4177fac4c95ab303bece3c8a7f080b85d40f.tar.bz2
gentoo-207a4177fac4c95ab303bece3c8a7f080b85d40f.zip
dev-python/requests-cache: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.7.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index c504192b9645..5cdc32e7bf77 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,2 +1,3 @@
DIST requests-cache-0.6.3.gh.tar.gz 50303 BLAKE2B e8507a19f3883c050e1d819bf9ce8ebf720a5c6517e4004ecf745f5a197a8feac9cbca18ffa99001be0baffbad41d2ebfba5b63d90b55eda1d754d279242bbc6 SHA512 1fa801f60623dce0a5cd834272a74acf80b6ae52a602ae81fbd7e3653467800d9a58fb8220e30d53ef1b896aa01f2017f93dcbc2dacfd685ee9ae286f47077f5
DIST requests-cache-0.6.4.gh.tar.gz 50322 BLAKE2B c9a6cae957604bdfa6057621e028fad83476e5d918bbf9c58e73f09f8615398946f3cf6e3737c9ff916cba68d82ed66a674557fb733c74b874b0f68e2430d9a0 SHA512 31e2217e54892d8ec5fc9fcf60f650960621b1f97029c90deca925b9a1be9eb5a3ddb6ae68e581c805f20136f93eefa70d51e7e9f086ecbae76f8e550bbe3f1a
+DIST requests-cache-0.7.1.gh.tar.gz 959455 BLAKE2B ce41514f21dc0708e437f70b92eb9d84f47433d04a11476cd5afefd050089e2d138213fa0b2f6bac200bd6d59db996187481ef3544d289a5117f3fe7160027b5 SHA512 cd83134ce9500c20c63fa92546cca41772ba3582a669914cd0885ec5aadf6ae4a6c4fc6a83dce73d2d5b24a80db2fde65cdb0a89b4b5703ddeac1d710404a05d
diff --git a/dev-python/requests-cache/requests-cache-0.7.1.ebuild b/dev-python/requests-cache/requests-cache-0.7.1.ebuild
new file mode 100644
index 000000000000..32b48e1d7368
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/reclosedev/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cattrs[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ # Requires Internet access
+ tests/integration/test_compat.py::test_version_upgrade
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest ${skipped_tests[@]/#/--deselect }
+}