summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-16 23:05:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-16 23:34:08 +0100
commit274951723b6b9c919e4e5d0d5b48b826151c624d (patch)
tree92155f97d2412d5ed325aef25ff2d9b1cb5ebb5d /dev-python/requests-credssp
parentdev-python/uvicorn: Bump to 0.17.5 (diff)
downloadgentoo-274951723b6b9c919e4e5d0d5b48b826151c624d.tar.gz
gentoo-274951723b6b9c919e4e5d0d5b48b826151c624d.tar.bz2
gentoo-274951723b6b9c919e4e5d0d5b48b826151c624d.zip
dev-python/requests-credssp: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-credssp')
-rw-r--r--dev-python/requests-credssp/Manifest1
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.3.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/requests-credssp/Manifest b/dev-python/requests-credssp/Manifest
index 05c5d94c1dc9..0a4085ab7a57 100644
--- a/dev-python/requests-credssp/Manifest
+++ b/dev-python/requests-credssp/Manifest
@@ -1 +1,2 @@
DIST requests-credssp-1.3.0.tar.gz 23666 BLAKE2B 3ab7db4c06a65483b26012b282a85174a50c9e9449fc33b90a22f7963bcd33c2b4642ce83f0632383e8c1fbc8dd4761fc00bc6d1adccb5cee020f0d67971f225 SHA512 6281ecd5d7e14792bd175603dfbb95237b990d5cad6e4c7252fd503b76c579590217194ecd3eb3120cb33cc4f2958be459e63fa3fa8d7411a8aa40d1666276b7
+DIST requests-credssp-1.3.1.tar.gz 23672 BLAKE2B e1c0134c02c3779301a8a8a803a6cc500779e9bfc319d3fa3f53bf5b8f5ce9f2624b5961d7586b205f3c1b005305d15b909ae05387a8af7448012ebe3f45bfbe SHA512 ff051b63705fca755a65202b930f622b6a3037455d43bdd2d1bb8726ed4a3a47f76b2d73c005d75d39f7c21048ac91a06abfdd5e88c014ea686a966d37535657
diff --git a/dev-python/requests-credssp/requests-credssp-1.3.1.ebuild b/dev-python/requests-credssp/requests-credssp-1.3.1.ebuild
new file mode 100644
index 000000000000..e0a776837c10
--- /dev/null
+++ b/dev-python/requests-credssp/requests-credssp-1.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTPS CredSSP authentication with the requests library"
+HOMEPAGE="https://pypi.org/project/requests-credssp/ https://github.com/jborean93/requests-credssp"
+SRC_URI="https://github.com/jborean93/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ dev-python/krb5[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
+ dev-python/pyspnego[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest