summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-01 15:15:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 15:16:39 +0100
commit5d0ac520552ced3322591a1520dac70062ca3e64 (patch)
tree7d4d8adb54b1fed6186436c3491c136cb053d9fc /dev-python/rich/rich-11.1.0.ebuild
parentdev-python/commonmark: Fix pypi homepage (diff)
downloadgentoo-5d0ac520552ced3322591a1520dac70062ca3e64.tar.gz
gentoo-5d0ac520552ced3322591a1520dac70062ca3e64.tar.bz2
gentoo-5d0ac520552ced3322591a1520dac70062ca3e64.zip
dev-python/rich: Add pypy3 love
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rich/rich-11.1.0.ebuild')
-rw-r--r--dev-python/rich/rich-11.1.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/rich/rich-11.1.0.ebuild b/dev-python/rich/rich-11.1.0.ebuild
index 76113d1d7315..7fab6ef8c8cf 100644
--- a/dev-python/rich/rich-11.1.0.ebuild
+++ b/dev-python/rich/rich-11.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1 optfeature
DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
@@ -25,6 +25,10 @@ RDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${P}-pypy3.patch
+)
+
python_test() {
local EPYTEST_DESELECT=(
# check for exact color render string, which changes across pygments bumps