summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 15:32:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 15:32:43 +0300
commit6b440763995cafc3236d10fdd715a0e8fdc8ab2b (patch)
treeecb916279d2940fe28bc26b9bc9e11dbf9b4782c /dev-python/rope/rope-1.3.0.ebuild
parentdev-python/dj-database-url: add 1.0.0 (diff)
downloadgentoo-6b440763995cafc3236d10fdd715a0e8fdc8ab2b.tar.gz
gentoo-6b440763995cafc3236d10fdd715a0e8fdc8ab2b.tar.bz2
gentoo-6b440763995cafc3236d10fdd715a0e8fdc8ab2b.zip
dev-python/rope: add 1.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rope/rope-1.3.0.ebuild')
-rw-r--r--dev-python/rope/rope-1.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rope/rope-1.3.0.ebuild b/dev-python/rope/rope-1.3.0.ebuild
new file mode 100644
index 000000000000..67e1183ee5b0
--- /dev/null
+++ b/dev-python/rope/rope-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/pytoolconfig[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)