summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-14 21:05:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-14 22:01:39 +0200
commit3a606b437f58d2fd9c6604d420c3f996412e8d9e (patch)
treee34b6f9ac38a8bdcd11658183663859d7f413bad /dev-python/rsa
parentdev-python/boto3: Enable py3.11 (diff)
downloadgentoo-3a606b437f58d2fd9c6604d420c3f996412e8d9e.tar.gz
gentoo-3a606b437f58d2fd9c6604d420c3f996412e8d9e.tar.bz2
gentoo-3a606b437f58d2fd9c6604d420c3f996412e8d9e.zip
dev-python/rsa: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rsa')
-rw-r--r--dev-python/rsa/rsa-4.8-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-4.8-r1.ebuild b/dev-python/rsa/rsa-4.8-r1.ebuild
new file mode 100644
index 000000000000..89faa14dd4b1
--- /dev/null
+++ b/dev-python/rsa/rsa-4.8-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-rsa-version-${PV}
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="
+ https://stuvel.eu/rsa/
+ https://github.com/sybrenstuvel/python-rsa/
+ https://pypi.org/project/rsa/
+"
+SRC_URI="
+ https://github.com/sybrenstuvel/python-rsa/archive/version-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ rm tests/test_mypy.py || die
+ distutils-r1_src_prepare
+}