summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-22 17:09:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-22 17:28:56 +0200
commit90e48423f7c0e5a1117b1790606e077f005596ec (patch)
treeffac02caeda02ea2e525a081cab474d2a3f4517a /dev-python/rst-linker/rst-linker-2.5.0.ebuild
parentdev-libs/boost: add 1.85.0 (diff)
downloadgentoo-90e48423f7c0e5a1117b1790606e077f005596ec.tar.gz
gentoo-90e48423f7c0e5a1117b1790606e077f005596ec.tar.bz2
gentoo-90e48423f7c0e5a1117b1790606e077f005596ec.zip
dev-python/rst-linker: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rst-linker/rst-linker-2.5.0.ebuild')
-rw-r--r--dev-python/rst-linker/rst-linker-2.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/rst-linker/rst-linker-2.5.0.ebuild b/dev-python/rst-linker/rst-linker-2.5.0.ebuild
new file mode 100644
index 000000000000..38460daa5311
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="
+ https://github.com/jaraco/rst.linker/
+ https://pypi.org/project/rst.linker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest