summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 08:59:49 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 08:59:49 +0100
commitf03547d1c8925f712aab5a4fae6926b85a18054d (patch)
tree80a9bf3342082d62f3e1655217dc517a19a7cb7a /dev-python/ruamel-yaml/ruamel-yaml-0.17.20.ebuild
parentdev-python/rich: Remove old (diff)
downloadgentoo-f03547d1c8925f712aab5a4fae6926b85a18054d.tar.gz
gentoo-f03547d1c8925f712aab5a4fae6926b85a18054d.tar.bz2
gentoo-f03547d1c8925f712aab5a4fae6926b85a18054d.zip
dev-python/ruamel-yaml: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml/ruamel-yaml-0.17.20.ebuild')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.20.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.20.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.20.ebuild
deleted file mode 100644
index c5d584c09124..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.20.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- [[ ${EPYTHON} == pypy3 ]] && local EPYTEST_DESELECT=(
- _test/test_deprecation.py::test_collections_deprecation
- )
- local EPYTEST_IGNORE=(
- _test/lib/
- )
- epytest
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}