summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-13 19:46:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-13 19:46:19 +0200
commite43243b7477e2bfc597b65c98b04eac1e4e1fda8 (patch)
tree55883f9048fbc22af51d2ae7bdde91e3bcc2f78e /dev-python/scandir/scandir-1.9.0.ebuild
parentsys-cluster/openmpi: bump 2.1.4 (diff)
downloadgentoo-e43243b7477e2bfc597b65c98b04eac1e4e1fda8.tar.gz
gentoo-e43243b7477e2bfc597b65c98b04eac1e4e1fda8.tar.bz2
gentoo-e43243b7477e2bfc597b65c98b04eac1e4e1fda8.zip
dev-python/scandir: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/scandir/scandir-1.9.0.ebuild')
-rw-r--r--dev-python/scandir/scandir-1.9.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/scandir/scandir-1.9.0.ebuild b/dev-python/scandir/scandir-1.9.0.ebuild
new file mode 100644
index 000000000000..f355a307197b
--- /dev/null
+++ b/dev-python/scandir/scandir-1.9.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A better directory iterator and faster os.walk()"
+HOMEPAGE="https://github.com/benhoyt/scandir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test/run_tests.py -v || die "tests failed under ${EPYTHON}"
+}