summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-05 05:56:19 +0000
committerSam James <sam@gentoo.org>2021-11-05 05:56:49 +0000
commit9def9edcf54f2472273e176973deb19c1cf1ea14 (patch)
tree1d567b3154820af9aecd36916e43f8e49db9298a /dev-python/scipy
parentdev-python/scipy: add upstream fix for 32-bit test failures (pythran) (diff)
downloadgentoo-9def9edcf54f2472273e176973deb19c1cf1ea14.tar.gz
gentoo-9def9edcf54f2472273e176973deb19c1cf1ea14.tar.bz2
gentoo-9def9edcf54f2472273e176973deb19c1cf1ea14.zip
dev-python/scipy: skip known-failing 32-bit tests
There's some more work in 1.7.2 (coming soon) which should help a bit. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.7.1-r1.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/scipy/scipy-1.7.1-r1.ebuild b/dev-python/scipy/scipy-1.7.1-r1.ebuild
index 0ef732f5b199..d93785afefa8 100644
--- a/dev-python/scipy/scipy-1.7.1-r1.ebuild
+++ b/dev-python/scipy/scipy-1.7.1-r1.ebuild
@@ -115,6 +115,21 @@ python_prepare_all() {
sed -e 's:test_bisplev_integer_overflow:_&:' \
-i scipy/interpolate/tests/test_fitpack.py || die
+ # Skip a few 32-bit related failures
+ if use x86 ; then
+ # TODO: Tidy this up and switch to epytest
+ sed -i -e 's:test_nd_axis_m1:_&:' \
+ -e 's:test_nd_axis_0:_&:' \
+ -e 's:test_maxiter_worsening:_&:' \
+ -e 's:test_pdist_jensenshannon_iris:_&:' \
+ -e 's:test_align_vectors_single_vector:_&:' \
+ scipy/signal/tests/test_spectral.py \
+ scipy/sparse/linalg/isolve/tests/test_iterative.py \
+ scipy/spatial/tests/test_distance.py \
+ scipy/spatial/transform/tests/test_rotation.py || die
+ fi
+
+
if has_version ">=sci-libs/lapack-3.10"; then
sed -e 's:test_sort(:_&:' \
-i scipy/linalg/tests/test_decomp.py || die