summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-11 20:29:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-11 20:29:25 +0200
commitebc876a3e3e7dae2b97c87f0a730eb6888eddee9 (patch)
treecba53af9d153083679f4e40ae812843c631e5333 /dev-python/seaborn
parentdev-python/pytest-system-statistics: Enable py3.13 (diff)
downloadgentoo-ebc876a3e3e7dae2b97c87f0a730eb6888eddee9.tar.gz
gentoo-ebc876a3e3e7dae2b97c87f0a730eb6888eddee9.tar.bz2
gentoo-ebc876a3e3e7dae2b97c87f0a730eb6888eddee9.zip
dev-python/seaborn: Fix tests with numpy-2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/seaborn-0.13.2.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/seaborn/seaborn-0.13.2.ebuild b/dev-python/seaborn/seaborn-0.13.2.ebuild
index b7d3e8825fc5..d873ae99d638 100644
--- a/dev-python/seaborn/seaborn-0.13.2.ebuild
+++ b/dev-python/seaborn/seaborn-0.13.2.ebuild
@@ -30,6 +30,13 @@ RDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/mwaskom/seaborn/pull/3685
+ sed -i -e '/VisibleDeprecationWarning/d' tests/test_distributions.py || die
+}
+
src_test() {
cat > matplotlibrc <<- EOF || die
backend : Agg