summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-07 04:58:36 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-07 05:00:31 +0200
commit0a8b2a5a71a74a2addf390c31e45991d4b28f6f6 (patch)
tree853ac9839bb87a6d3ba71f4c94802639f160649b /dev-python/send2trash
parentdev-python/jaraco-context: Bump to 5.3.0 (diff)
downloadgentoo-0a8b2a5a71a74a2addf390c31e45991d4b28f6f6.tar.gz
gentoo-0a8b2a5a71a74a2addf390c31e45991d4b28f6f6.tar.bz2
gentoo-0a8b2a5a71a74a2addf390c31e45991d4b28f6f6.zip
dev-python/send2trash: Bump to 1.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/send2trash')
-rw-r--r--dev-python/send2trash/Manifest1
-rw-r--r--dev-python/send2trash/send2trash-1.8.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/send2trash/Manifest b/dev-python/send2trash/Manifest
index 0da980374d2a..b8c43f852c4d 100644
--- a/dev-python/send2trash/Manifest
+++ b/dev-python/send2trash/Manifest
@@ -1 +1,2 @@
DIST Send2Trash-1.8.2.tar.gz 17487 BLAKE2B 3362a7e0c70f0e3f0f7a64676174d6c6f28290079590e08e4a746c0e19f96deca028aa521df58afa7f0ab47d78f286df01f98e903dfd771063af0ff40b4f6c08 SHA512 378107c8175e8d08566258daa13d3000e66ec03f732698180a2eb7f862c39d3c458be66ecf3f8864f559b961e29b777b8e7f5169468219e19723def62a69bb9c
+DIST Send2Trash-1.8.3.tar.gz 17394 BLAKE2B 55f382ae81b2279214023daad3a7a8ac0d5f55ebbbe9a2c7af02d35b980f3342ecc5f9b4e734d3c233b65a1fdd058ed856b7a96f3685ebbf1eb4c7dd9d37e159 SHA512 81b9d6ce00830414daac0e1cafe2b69d42b750146f45e64c27750ee8f6d81f771145852a96bf51afa944d8c31959b8c9ac1b5e05c8793732039b690107789d93
diff --git a/dev-python/send2trash/send2trash-1.8.3.ebuild b/dev-python/send2trash/send2trash-1.8.3.ebuild
new file mode 100644
index 000000000000..816b76361a12
--- /dev/null
+++ b/dev-python/send2trash/send2trash-1.8.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=Send2Trash
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sends files to the Trash (or Recycle Bin)"
+HOMEPAGE="
+ https://github.com/arsenetar/send2trash/
+ https://pypi.org/project/Send2Trash/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest