summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-02-03 13:21:12 -0800
committerPatrick McLean <chutzpah@gentoo.org>2017-02-03 13:21:12 -0800
commitbb73b416efaeae146ec8ac26dc0a3d7196e5cb5a (patch)
treee99eb1c77074fe2106a8c15734d2d7e82ccb21cb /dev-python/sh
parenttoolchain.eclass: fix a typo in a comment (diff)
downloadgentoo-bb73b416efaeae146ec8ac26dc0a3d7196e5cb5a.tar.gz
gentoo-bb73b416efaeae146ec8ac26dc0a3d7196e5cb5a.tar.bz2
gentoo-bb73b416efaeae146ec8ac26dc0a3d7196e5cb5a.zip
dev-python/sh: Version bump to 1.12.9
Gentoo-Bug: 608016 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch22
-rw-r--r--dev-python/sh/sh-1.12.9.ebuild30
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 2b4f082daaf0..e2519534c5da 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-1.11.tar.gz 36821 SHA256 590fb9b84abf8b1f560df92d73d87965f1e85c6b8330f8a5f6b336b36f0559a4 SHA512 ccaf178384b5a609c00bb44796a6bec088750414385f19b2d8ffcb93cc8f5ddb6bf82fb966d2bf519651f6efed54258a3c6542a9827d01e6be64af8cb8f86d3d WHIRLPOOL 9d13a3364ec467b492fb5818ae00e3a02f81aa779319382450df76a3041efb047dac82bd249cb51bf819664a5e7a8f9def3a672b8eb2edaa24f2a2aa80d66129
+DIST sh-1.12.9.tar.gz 54077 SHA256 579aa19bae7fe86b607df1afaf4e8537c453d2ce3d84e1d3957e099359a51677 SHA512 378ebfe148de6d1fb0f6488a42a39570f1fde6bb2d3ce40cbe29a6920e102f4c31d38a686663e52b2968099d85a0b5867e112c5d53ca0a4527a2f2bc9e607d35 WHIRLPOOL af177f97f21db7df68a8645fc5da83721ae10961df1ff441a816b028bdd4177b1f197d541c91cb1542c4cedf19eb6bcd1ac0576ccd2cce8ec6d5e0e4e19adbb5
diff --git a/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch b/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch
new file mode 100644
index 000000000000..230b16ae5fb1
--- /dev/null
+++ b/dev-python/sh/files/sh-1.12.9-python2-unicode-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/test.py b/test.py
+index 78e00ab..0487594 100644
+--- a/test.py
++++ b/test.py
+@@ -502,7 +502,7 @@ for key in osx_cruft:
+ print(os.environ["HERP"] + " " + str(len(os.environ)))
+ """ % osx_cruft)
+ out = python(py.name, _env=env).strip()
+- self.assertEqual(out, "DERP 1")
++ self.assertEqual(out, u"DERP 12")
+
+ py = create_tmp_test("""
+ import os, sys
+@@ -515,7 +515,7 @@ for key in osx_cruft:
+ print(sh.HERP + " " + str(len(os.environ)))
+ """ % osx_cruft)
+ out = python(py.name, _env=env, _cwd=THIS_DIR).strip()
+- self.assertEqual(out, "DERP 1")
++ self.assertEqual(out, u"DERP 12")
+
+
+ def test_which(self):
diff --git a/dev-python/sh/sh-1.12.9.ebuild b/dev-python/sh/sh-1.12.9.ebuild
new file mode 100644
index 000000000000..cb703741760d
--- /dev/null
+++ b/dev-python/sh/sh-1.12.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.9-python2-unicode-tests.patch"
+)
+
+python_test() {
+ ${PYTHON} test.py || die
+}