summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2020-06-15 15:45:51 +0200
committerAndrey Utkin <andrey_utkin@gentoo.org>2020-09-01 21:17:07 +0100
commitd299a9d6a0b4e40b2645186d2f900d546ef55d70 (patch)
tree9f78a1bf21699ab9cd5cbd82ce2674b4b67356a6 /dev-python/slixmpp/slixmpp-1.5.2.ebuild
parentnet-ftp/proftpd: Stabilize 1.3.7a amd64, #738674 (diff)
downloadgentoo-d299a9d6a0b4e40b2645186d2f900d546ef55d70.tar.gz
gentoo-d299a9d6a0b4e40b2645186d2f900d546ef55d70.tar.bz2
gentoo-d299a9d6a0b4e40b2645186d2f900d546ef55d70.zip
dev-python/slixmpp: add ebuild for version 1.5.2
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/slixmpp/slixmpp-1.5.2.ebuild')
-rw-r--r--dev-python/slixmpp/slixmpp-1.5.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/slixmpp/slixmpp-1.5.2.ebuild b/dev-python/slixmpp/slixmpp-1.5.2.ebuild
new file mode 100644
index 000000000000..eb42815f81e4
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest