summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-26 08:48:19 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-26 08:48:59 +0200
commitd7a2eacac5df35da05ce873c816ccc04ebd6e606 (patch)
treef1b46bd544ce96288343ef2d9e0dee0cb371083d /dev-python/smbus2/smbus2-0.4.2.ebuild
parentdev-lang/spidermonkey: drop 102.1.0-r1 (diff)
downloadgentoo-d7a2eacac5df35da05ce873c816ccc04ebd6e606.tar.gz
gentoo-d7a2eacac5df35da05ce873c816ccc04ebd6e606.tar.bz2
gentoo-d7a2eacac5df35da05ce873c816ccc04ebd6e606.zip
dev-python/smbus2: new package, add 0.4.2
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-python/smbus2/smbus2-0.4.2.ebuild')
-rw-r--r--dev-python/smbus2/smbus2-0.4.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/smbus2/smbus2-0.4.2.ebuild b/dev-python/smbus2/smbus2-0.4.2.ebuild
new file mode 100644
index 000000000000..5b40ab7fc370
--- /dev/null
+++ b/dev-python/smbus2/smbus2-0.4.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A drop-in replacement for smbus-cffi/smbus-python in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/smbus2/
+ https://github.com/kplindegaard/smbus2
+"
+SRC_URI="
+ https://github.com/kplindegaard/smbus2/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests nose