summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-03-06 22:30:20 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-03-07 00:17:18 +0000
commita06e6a36af116d6178f3efb66712da7e99e376f8 (patch)
tree44cb81dd0a548f86b6ee6dee2ecd8a05cbac755e /dev-python/sortedcontainers
parentdev-python/tblib: initial import (diff)
downloadgentoo-a06e6a36af116d6178f3efb66712da7e99e376f8.tar.gz
gentoo-a06e6a36af116d6178f3efb66712da7e99e376f8.tar.bz2
gentoo-a06e6a36af116d6178f3efb66712da7e99e376f8.zip
dev-python/sortedcontainers: initial import
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/sortedcontainers')
-rw-r--r--dev-python/sortedcontainers/Manifest1
-rw-r--r--dev-python/sortedcontainers/metadata.xml15
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/Manifest b/dev-python/sortedcontainers/Manifest
new file mode 100644
index 000000000000..158695a2b402
--- /dev/null
+++ b/dev-python/sortedcontainers/Manifest
@@ -0,0 +1 @@
+DIST sortedcontainers-1.5.7.tar.gz 11970881 SHA256 0ff0442865e492bc50476b18000fb8400cf2472d14d21a92b27cd7c5184550ea SHA512 a9f2ba152c47eddfda6ad8ef7ecfbfa5d51b17afb4042b0b1e6d8b3dbc6caf6f8281af415dfcf1e356aaf80aa3212865ba926fe0d6e08961c8fbbc68adb34108 WHIRLPOOL ac1c64a49705b2a02d2eb05e8306a1ee21d494819b7331256fc8c17d5fda89c82eaf2267981408c9de92bde0c4569a0e87fa4d7d12297881c4b8b295b1df9788
diff --git a/dev-python/sortedcontainers/metadata.xml b/dev-python/sortedcontainers/metadata.xml
new file mode 100644
index 000000000000..3853ea8fb1f6
--- /dev/null
+++ b/dev-python/sortedcontainers/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python Sorted Container Types: SortedList, SortedDict, and SortedSet
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sortedcontainers</remote-id>
+ <remote-id type="github">grantjenks/sorted_containers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild b/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild
new file mode 100644
index 000000000000..3bfb25bb8185
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-1.5.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/"
+SRC_URI="mirror://pypi/$(echo ${PN} | cut -c 1)/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}