summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 17:38:58 +0200
committerSam James <sam@gentoo.org>2022-06-29 17:49:24 +0000
commit57fbfec14cffa437c1948fe9bb738fd690d5275c (patch)
treea2a56704d029fee47bd7f2363780cfae5081c693 /dev-python/sphinx-basic-ng
parentdistutils-r1.eclass: Adjust min dep versions to current stable (diff)
downloadgentoo-57fbfec14cffa437c1948fe9bb738fd690d5275c.tar.gz
gentoo-57fbfec14cffa437c1948fe9bb738fd690d5275c.tar.bz2
gentoo-57fbfec14cffa437c1948fe9bb738fd690d5275c.zip
dev-python/sphinx-basic-ng: New package, v0.0.1_alpha11
New NIH dep for dev-python/furo. Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-basic-ng')
-rw-r--r--dev-python/sphinx-basic-ng/Manifest1
-rw-r--r--dev-python/sphinx-basic-ng/metadata.xml11
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/Manifest b/dev-python/sphinx-basic-ng/Manifest
new file mode 100644
index 000000000000..8d370c8ca62b
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/Manifest
@@ -0,0 +1 @@
+DIST sphinx-basic-ng-0.0.1.a11.gh.tar.gz 21539 BLAKE2B 31707bc8f3c6cd0c1af1aeff309543889119d33e5f5ae33194b58f88a0ff6ec424c5b876fef36b64161932ebb69c0f6108801697b49d47e10ad13affcf89e1fa SHA512 e9f9278a360d2c8d25a6679134d2d54b37c9f2e55285592fa910c85b2f8bfd4ab13d117b7078cb67d862703f8054c3d3a3ca68152551d67a26d7c1a8b75952ff
diff --git a/dev-python/sphinx-basic-ng/metadata.xml b/dev-python/sphinx-basic-ng/metadata.xml
new file mode 100644
index 000000000000..43822aecf33b
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pradyunsg/sphinx-basic-ng</remote-id>
+ <remote-id type="pypi">sphinx-basic-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild
new file mode 100644
index 000000000000..6f6d42d32673
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_alpha/.a}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_alpha/.a}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/sphinx-6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}