summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 08:05:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 09:19:57 +0100
commitb76d0566fb3f27acd95524977ed70d9726144b67 (patch)
treebe794bfb3d0b23598a7e4a949ee3cbbcf7323314 /dev-python/sphinxcontrib-applehelp
parentdev-python/sphinxcontrib-devhelp: Bump to 1.0.6 (diff)
downloadgentoo-b76d0566fb3f27acd95524977ed70d9726144b67.tar.gz
gentoo-b76d0566fb3f27acd95524977ed70d9726144b67.tar.bz2
gentoo-b76d0566fb3f27acd95524977ed70d9726144b67.zip
dev-python/sphinxcontrib-applehelp: Bump to 1.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp')
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
index 297cb74c69a1..fa28d625db11 100644
--- a/dev-python/sphinxcontrib-applehelp/Manifest
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib_applehelp-1.0.7.tar.gz 19543 BLAKE2B c44cdb9403fc9272e5220f23b3ce6d9eb63f754b526b450d857f0260e92ab92e35bf814df40ba11186ae7bbd070516fdccf475c8777113393327c33afd42eb07 SHA512 8ab1e8ce73591a32c4d73d022ad87e003e6fba36bf4f670f7b9a6b213ed8f396506d8e2998182e19ec9c7ccf21e7d52b5de9b7a8ca0ed676738c4e10fbd738b2
+DIST sphinxcontrib_applehelp-1.0.8.tar.gz 19674 BLAKE2B f449cdc28cbf8374cdfa5bdacb501c3bfc8a4a93c855c220e66989d538f76653ddf4b81fb0534dd043771b60d0de01c9d3c30cecfb02cbb2fc0c0cd2320b377d SHA512 0afd38caf07e60b45b47e7e1cc8dea0d34578f7501a6000c6bc860454bb71d8c9d59c7b66ee39c173d635c1944735782762e713598d99dd4fefda51ccd1d74d3
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild
new file mode 100644
index 000000000000..76a136b509fb
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp/
+ https://pypi.org/project/sphinxcontrib-applehelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest