summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 07:59:21 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 09:19:53 +0100
commit5402bca88b253479fd09d39666d036c1b865bed5 (patch)
tree6b7d500a5acddceb1c60b1b2876c6d3c5526b050 /dev-python/sphinxcontrib-websupport
parentdev-python/pyspelling: Bump to 2.10 (diff)
downloadgentoo-5402bca88b253479fd09d39666d036c1b865bed5.tar.gz
gentoo-5402bca88b253479fd09d39666d036c1b865bed5.tar.bz2
gentoo-5402bca88b253479fd09d39666d036c1b865bed5.zip
dev-python/sphinxcontrib-websupport: Bump to 1.2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-websupport')
-rw-r--r--dev-python/sphinxcontrib-websupport/Manifest1
-rw-r--r--dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-websupport/Manifest b/dev-python/sphinxcontrib-websupport/Manifest
index 39dd0eeddf2f..131b69afd807 100644
--- a/dev-python/sphinxcontrib-websupport/Manifest
+++ b/dev-python/sphinxcontrib-websupport/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib_websupport-1.2.6.tar.gz 599139 BLAKE2B 661ba75c1a222993b558d2bcad0d76e99083ef8d2006526ac8d4f95228d93cb80f68638ba4e5fa245fd79e9bef13babbfcfb6c6decb1a02dd2e2623f37e88374 SHA512 d3085083132cbd9fcd289aff56a72c44f0ed8803e60996c1542da0ca1eaee7f3f38ddd2c45fc44045206091615cf69bc11bb60fb2f95ab5c6dadc2ef65251155
+DIST sphinxcontrib_websupport-1.2.7.tar.gz 599362 BLAKE2B 544e77a739e0ecd9391893f56eeec2df4d5ddc6840a30e9a92e84e35e9ed0a765d4190790a13e329621ba045ee46b5e01d4d0825b6f37e9848953f9e796ae8af SHA512 daa5ecf6fd3fb6df6a9a3b60668d42d50d93454dc3c2703a1dd43d75220b326e90c5e0ae2cca27afe62e41ae03e7144e6b4cfe70096b857af74c8981fadba9ca
diff --git a/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild
new file mode 100644
index 000000000000..b1fe70d9cf12
--- /dev/null
+++ b/dev-python/sphinxcontrib-websupport/sphinxcontrib-websupport-1.2.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx websupport extension"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-websupport/
+ https://pypi.org/project/sphinxcontrib-websupport/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+"
+# avoid circular dependency with sphinx
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+# there are additional optional test deps on sqlalchemy and whoosh
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest