summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-16 01:09:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-16 01:20:31 +0100
commit6b4f23361519ef33387db0c000d7fc47211b34dd (patch)
treed1a06336cc8127bfc2c8c0eaa147458c99d5a77a /dev-python/sqlalchemy
parentmedia-libs/libexif: Stabilize 0.6.22_p20201105 amd64, #754681 (diff)
downloadgentoo-6b4f23361519ef33387db0c000d7fc47211b34dd.tar.gz
gentoo-6b4f23361519ef33387db0c000d7fc47211b34dd.tar.bz2
gentoo-6b4f23361519ef33387db0c000d7fc47211b34dd.zip
dev-python/sqlalchemy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/files/sqlalchemy-pytest-deprecation.patch67
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.3.11.ebuild64
3 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index c5caff9cd008..051c2b70a88b 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,3 +1,2 @@
-DIST SQLAlchemy-1.3.11.tar.gz 6007784 BLAKE2B c889ea28ae08fcb83d338ab01a64533142428ee91a6c11b9a7f2116f99161c066e66f49d76bdd2c7600f1a7f86a2add217f49dda4cf97566a875f28d3d4b24be SHA512 c691539db4edd62af749087728dfd424010bfb3ca2cc8503a4b96c1625d059d4c2a748b9a35cc870cc99ca9df61966cce406f9b570b25e55c3632a99b8621e74
DIST SQLAlchemy-1.3.17.tar.gz 5979141 BLAKE2B f0fa46493461f532ebca9420fc9f49a2c04af888aa99653946a5bb563d40b8bb714a03301300ebb80cca76a99f8226ddfcde4216e8fc2593d3a161b5072276ab SHA512 6f6d54b9018ece6c289f28a3a41ffb1b2216206edee08c49f387e9f30740969dfe0f8272654ce4efca159a2a6619e76c41b2ad2b10c391cdd64681ac17d0bc79
DIST SQLAlchemy-1.3.20.tar.gz 6264898 BLAKE2B 4c386eff56c2f9ec7ef467e3bc0032629582a970707dc11e3744fe3903d9cb18457f5e0be4dc9c20727b5733f158e031bf8b40f586dadb8f4ab8d0cae3cf7398 SHA512 29c52ada1a66f906ed2563df2ab093eceb7c09de45749c96031f30a1512d20b1d698e00640c777169ef3db99ab012151770a3daea45a51df934269b554ff4b28
diff --git a/dev-python/sqlalchemy/files/sqlalchemy-pytest-deprecation.patch b/dev-python/sqlalchemy/files/sqlalchemy-pytest-deprecation.patch
deleted file mode 100644
index ee09a7312e6a..000000000000
--- a/dev-python/sqlalchemy/files/sqlalchemy-pytest-deprecation.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 993e6449e3f5f3532f6f5426b824718435ce6c6d Mon Sep 17 00:00:00 2001
-From: Mike Bayer <mike_mp@zzzcomputing.com>
-Date: Thu, 12 Mar 2020 19:44:37 -0400
-Subject: [PATCH] Dont raise on pytest deprecation warnings
-
-py.test 5.4.0 emits deprecation warnings for pytest.Class.
-make sure we don't raise for these, and log the code that will
-be used for 5.4.0 when we bump requirements.
-
-Fixes: #5201
-Change-Id: I83e0402c4a6b2365a63b58d052c6989df3a37328
----
- lib/sqlalchemy/testing/plugin/pytestplugin.py | 13 +++++++++++++
- lib/sqlalchemy/testing/warnings.py | 9 +++++++++
- 3 files changed, 29 insertions(+)
-
-diff --git a/lib/sqlalchemy/testing/plugin/pytestplugin.py b/lib/sqlalchemy/testing/plugin/pytestplugin.py
-index c39f9f32e..f2e7d706f 100644
---- a/lib/sqlalchemy/testing/plugin/pytestplugin.py
-+++ b/lib/sqlalchemy/testing/plugin/pytestplugin.py
-@@ -160,6 +160,11 @@ def pytest_collection_modifyitems(session, config, items):
- if sub_cls is not test_class.cls:
- per_cls_dict = rebuilt_items[test_class.cls]
-
-+ # in pytest 5.4.0
-+ # for inst in pytest.Class.from_parent(
-+ # test_class.parent.parent, name=sub_cls.__name__
-+ # ).collect():
-+
- for inst in pytest.Class(
- sub_cls.__name__, parent=test_class.parent.parent
- ).collect():
-@@ -188,6 +193,14 @@ def pytest_collection_modifyitems(session, config, items):
- def pytest_pycollect_makeitem(collector, name, obj):
-
- if inspect.isclass(obj) and plugin_base.want_class(name, obj):
-+
-+ # in pytest 5.4.0
-+ # return [
-+ # pytest.Class.from_parent(collector,
-+ # name=parametrize_cls.__name__)
-+ # for parametrize_cls in _parametrize_cls(collector.module, obj)
-+ # ]
-+
- return [
- pytest.Class(parametrize_cls.__name__, parent=collector)
- for parametrize_cls in _parametrize_cls(collector.module, obj)
-diff --git a/lib/sqlalchemy/testing/warnings.py b/lib/sqlalchemy/testing/warnings.py
-index cc11e556c..6b42c98cb 100644
---- a/lib/sqlalchemy/testing/warnings.py
-+++ b/lib/sqlalchemy/testing/warnings.py
-@@ -34,6 +34,15 @@ def setup_filters():
- # ignore 2.0 warnings unless we are explicitly testing for them
- warnings.filterwarnings("ignore", category=sa_exc.RemovedIn20Warning)
-
-+ try:
-+ import pytest
-+ except ImportError:
-+ pass
-+ else:
-+ warnings.filterwarnings(
-+ "once", category=pytest.PytestDeprecationWarning
-+ )
-+
-
- def assert_warnings(fn, warning_msgs, regex=False):
- """Assert that each of the given warnings are emitted by fn.
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.3.11.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.3.11.ebuild
deleted file mode 100644
index ede4b5dfa758..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-1.3.11.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="sqlite?"
-
-inherit distutils-r1 flag-o-matic optfeature
-
-MY_PN="SQLAlchemy"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
-HOMEPAGE="https://www.sqlalchemy.org/ https://pypi.org/project/SQLAlchemy/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="doc examples +sqlite test"
-
-REQUIRED_USE="test? ( sqlite )"
-
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/sqlalchemy-pytest-deprecation.patch
- )
- # Disable tests hardcoding function call counts specific to Python versions.
- rm -r test/aaa_profiling || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/. )
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "MySQL support" dev-python/mysql-python dev-python/mysql-connector-python
- optfeature "mssql support" dev-python/pymssql
- optfeature "postgresql support" dev-python/psycopg:2
-}