summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-02-20 09:25:36 -0600
committerBen Kohler <bkohler@gentoo.org>2021-02-20 09:33:57 -0600
commitad43119aac4fd8731fe71447a6d59beb12846943 (patch)
treecf7abedb6499cb8704b2e5f52e50c4719edabbfc /dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild
parentapp-portage/mirrorselect: add python3_9 support (diff)
downloadgentoo-ad43119aac4fd8731fe71447a6d59beb12846943.tar.gz
gentoo-ad43119aac4fd8731fe71447a6d59beb12846943.tar.bz2
gentoo-ad43119aac4fd8731fe71447a6d59beb12846943.zip
dev-python/stapler: revbump for RDEPEND change
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild')
-rw-r--r--dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild b/dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild
new file mode 100644
index 000000000000..d71209069acb
--- /dev/null
+++ b/dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 vcs-snapshot
+
+COMMIT="1cabc85521e2badfc1e0d690086e286e701c2d9e"
+
+DESCRIPTION="Suite of tools for PDF files manipulation written in Python"
+HOMEPAGE="https://github.com/hellerbarde/stapler"
+SRC_URI="https://github.com/hellerbarde/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+"