summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-20 16:28:23 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-20 17:35:42 +0100
commit6eefc82068c2cc8c800fca9c2b70f3b8c407bc03 (patch)
treeff4f90ab44811a5adc5f0b8b0f3ab6bce1c27741 /dev-python/sure/sure-1.2.24.ebuild
parentdev-python/werkzeug: Version Bump (diff)
downloadgentoo-6eefc82068c2cc8c800fca9c2b70f3b8c407bc03.tar.gz
gentoo-6eefc82068c2cc8c800fca9c2b70f3b8c407bc03.tar.bz2
gentoo-6eefc82068c2cc8c800fca9c2b70f3b8c407bc03.zip
dev-python/sure: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/sure/sure-1.2.24.ebuild')
-rw-r--r--dev-python/sure/sure-1.2.24.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sure/sure-1.2.24.ebuild b/dev-python/sure/sure-1.2.24.ebuild
new file mode 100644
index 000000000000..eb3ec23b12d0
--- /dev/null
+++ b/dev-python/sure/sure-1.2.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility belt for automated testing in python for python"
+HOMEPAGE="https://github.com/gabrielfalcao/sure"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ~dev-python/rednose-0.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${CDEPEND} )
+"
+RDEPEND="${CDEPEND}"
+
+python_prepare_all() {
+ sed \
+ -e "82s/read_version()/'${PV}'/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v -s tests --rednose || die "Tests failed under ${EPYTHON}"
+}