summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 16:56:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 17:02:32 +0200
commit262fa4cab68435478b630b5939809a2faf8df5c4 (patch)
tree296202717e31910dbeccdca613bb91f4593889fe /dev-python/tekore
parentdev-python/sphinx-autodoc-typehints: import from ::guru (diff)
downloadgentoo-262fa4cab68435478b630b5939809a2faf8df5c4.tar.gz
gentoo-262fa4cab68435478b630b5939809a2faf8df5c4.tar.bz2
gentoo-262fa4cab68435478b630b5939809a2faf8df5c4.zip
dev-python/tekore: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/metadata.xml14
-rw-r--r--dev-python/tekore/tekore-3.7.1.ebuild44
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
new file mode 100644
index 000000000000..18eb751ff376
--- /dev/null
+++ b/dev-python/tekore/Manifest
@@ -0,0 +1 @@
+DIST tekore-3.7.1.tar.gz 258235 BLAKE2B e04edfab294ac3dac1fb086f296bf3fcc463cdad981d435fdd19ec812f1bb2ff79cacaa94d5105dc1070dd56602cc9a502537c68020cb27b2eb5b3c93788f193 SHA512 ed315a0b5b071265d2ba12d996bedafdea87286fd1beecc14d247176f2bdd2245e0220fb186ce4bd6eec2bc13a764f74b067ce1e546d8c30e618a4bdc3bf02e0
diff --git a/dev-python/tekore/metadata.xml b/dev-python/tekore/metadata.xml
new file mode 100644
index 000000000000..7908fd78d76a
--- /dev/null
+++ b/dev-python/tekore/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">felix-hilden/tekore</remote-id>
+ <remote-id type="pypi">tekore</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/tekore/tekore-3.7.1.ebuild b/dev-python/tekore/tekore-3.7.1.ebuild
new file mode 100644
index 000000000000..128ffe74a887
--- /dev/null
+++ b/dev-python/tekore/tekore-3.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io
+ https://github.com/felix-hilden/tekore
+"
+SRC_URI="https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/httpx-0.11[${PYTHON_USEDEP}]
+ <dev-python/httpx-0.18[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ >=dev-python/pytest-asyncio-0.11[${PYTHON_USEDEP}]
+ <dev-python/pytest-asyncio-0.15[${PYTHON_USEDEP}]
+)"
+
+DOCS="readme.rst"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/src \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
+
+python_prepare_all() {
+ # requires network
+ sed -i -e 's:test_bad_arguments_raises_error:_&:' \
+ tests/auth/expiring.py || die
+
+ distutils-r1_python_prepare_all
+}