summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 17:01:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 17:42:27 +0200
commit4b38676a44045d5a32bb0aa11d45734aee9fab9d (patch)
tree08e4768834e5f9e3ae0b96335df7619e88178fd5 /dev-python/testresources
parentdev-python/testtools: Bump to 2.4.0 (diff)
downloadgentoo-4b38676a44045d5a32bb0aa11d45734aee9fab9d.tar.gz
gentoo-4b38676a44045d5a32bb0aa11d45734aee9fab9d.tar.bz2
gentoo-4b38676a44045d5a32bb0aa11d45734aee9fab9d.zip
dev-python/testresources: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testresources')
-rw-r--r--dev-python/testresources/testresources-2.0.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/testresources/testresources-2.0.1.ebuild b/dev-python/testresources/testresources-2.0.1.ebuild
index 9b480a2aef84..2656fe9e2c07 100644
--- a/dev-python/testresources/testresources-2.0.1.ebuild
+++ b/dev-python/testresources/testresources-2.0.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -17,15 +17,13 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/testtools[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
)"
-RDEPEND=""
python_prepare_all() {
sed \