summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-02 08:20:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-02 10:29:14 +0200
commit05801fe5bbeba720b7bc8088eadaadad773aa9ff (patch)
tree7359b8f49615ab874f341878ccbe7f878c41e65b /dev-python/threadpoolctl
parentdev-python/boto3: Bump to 1.14.15 (diff)
downloadgentoo-05801fe5bbeba720b7bc8088eadaadad773aa9ff.tar.gz
gentoo-05801fe5bbeba720b7bc8088eadaadad773aa9ff.tar.bz2
gentoo-05801fe5bbeba720b7bc8088eadaadad773aa9ff.zip
dev-python/threadpoolctl: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index f6f9348b4134..f9569de5dd16 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1 +1,2 @@
DIST threadpoolctl-2.0.0.tar.gz 23349 BLAKE2B d7752d862f8de5d61a95dd2e0db9a9cf5b3fde4c13cad9f654c0af4e2277b8bcc36b79028fbdf0e14af35daacee4b01a8778462364e070eaa194af65f4274739 SHA512 8ce823a6aef9f6d6af73e848c7a3bb1c7eee3f94bf480ca056ed5f435655756b9ad26cb71e392689cd8e6a34ee1ddfcf0d8510e424ac9c05bb1eda679d0f7a93
+DIST threadpoolctl-2.1.0.tar.gz 25255 BLAKE2B 3afa8e8c44567d3833dee89e761b2f384129c386c5c5b9d8084c1b301f007be7f461f1ef99738e06551f793feefa5c312dce1d608e7012215fd759866a52e2d4 SHA512 09b745b0d164bf3fc4f293bd92f1fd2e02180ec538bf3da1cdb986e31d9336ba3e1301aede72f53700d00298bae7b91b4ec8fa3212accb4cde6c3f5f88ff5c62
diff --git a/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild
new file mode 100644
index 000000000000..1d26d7c49723
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-2.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# tests require openmp python bindings...
+RESTRICT=test
+
+distutils_enable_tests pytest