summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-14 06:53:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-14 07:33:46 +0200
commit99e75d3be64fd4fb610b79f243d9fe93548249d8 (patch)
treea8ea278235759d4366244ed28442d95dd4dd83bf /dev-python/threadpoolctl
parentdev-python/click: Bump to 8.1.5 (diff)
downloadgentoo-99e75d3be64fd4fb610b79f243d9fe93548249d8.tar.gz
gentoo-99e75d3be64fd4fb610b79f243d9fe93548249d8.tar.bz2
gentoo-99e75d3be64fd4fb610b79f243d9fe93548249d8.zip
dev-python/threadpoolctl: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 04471494d275..d31d8d75641b 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1 +1,2 @@
DIST threadpoolctl-3.1.0.tar.gz 29899 BLAKE2B 41bddace1231107a108fd57e281541a4e9f04c9bee957d16cfbff49361f9dcb0b879bf376617480b1ca2929c09d07fd1f8f704afa4ad85e34e38c4a82fb48a3c SHA512 551dad4c93a62382583a96187f795aaeb6954700647c984ad618d3d1bede50d6859e75f676c557fa875db37c798c0347131f6b136148f71b8208783c7f8f717e
+DIST threadpoolctl-3.2.0.gh.tar.gz 32196 BLAKE2B 662b2ab6908719c11881dbaba00437b049f71dc8b6c5c8f4c3733cd156312a6410eca19d0446e11cfaddd039261adb25398a3827e822584ad52b428e67fc6b17 SHA512 01017047ceaa353239fea5410be3b6cd924068d7e18a80bc04cc07f08341e3405fa8620a8e5f43f16b674a3ce535d15e42b41741f78079fb61e618c8b9d1583d
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
new file mode 100644
index 000000000000..c80290ae5121
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="
+ https://github.com/joblib/threadpoolctl/
+ https://pypi.org/project/threadpoolctl/
+"
+SRC_URI="
+ https://github.com/joblib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+)