summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-02 19:58:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-02 20:44:16 +0100
commit050de4f72e6143f8f98f5c48ef2f10e85bbe1981 (patch)
treebda4c4dd22641887c90c3b53ea653e4df6a84fa4 /dev-python/tomlkit
parentdev-python/sqlalchemy: Bump to 2.0.23 (diff)
downloadgentoo-050de4f72e6143f8f98f5c48ef2f10e85bbe1981.tar.gz
gentoo-050de4f72e6143f8f98f5c48ef2f10e85bbe1981.tar.bz2
gentoo-050de4f72e6143f8f98f5c48ef2f10e85bbe1981.zip
dev-python/tomlkit: Bump to 0.12.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tomlkit')
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.12.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index 276cf4f78dd6..8ea2b264b4d5 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1 +1,2 @@
DIST tomlkit-0.12.1.tar.gz 190535 BLAKE2B 461891b5f5dad93488d466560439e19865fcb315792418e24483c96f4c9387c67d9c322bcc4ba842861109ff3297e064cd38737769d97ad1f99dadd9c11f7b33 SHA512 1f82023cbb8168f847bfa0211ee5c4d6870973ee1f51f4b60deb34ae6e0e930fe299c939b6c157811d16a73c68225a468e8312ca2731e1bbdcc5541fde2e2360
+DIST tomlkit-0.12.2.tar.gz 190725 BLAKE2B f168f42e99cbd8ed5d958ec471fc824d3a89f72d0d68b8881c5c935d888f1b0464e6ca34e65741a9de9d98c093a1e23073378006693bbd6c85870f368291760a SHA512 c36405e95ab42e1e728b4344dd71d183c2e8c174b3524d3337af2456e141f5a54fed82c1f613d5493efef50170f2985f74b1e5859790e865379fab7f90f03c65
diff --git a/dev-python/tomlkit/tomlkit-0.12.2.ebuild b/dev-python/tomlkit/tomlkit-0.12.2.ebuild
new file mode 100644
index 000000000000..b8055655dd0a
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.12.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "poetry' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "tomlkit"
+ version = "${PV}"
+ description = "Style preserving TOML library"
+ EOF
+}