summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-25 04:41:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-25 05:02:43 +0100
commitf8e04db05c4f80921c8b4a84c1bb722befb1a80d (patch)
treedf7ad16ab63b84fa7dacf0f97eb1e6257f43f038 /dev-python/tqdm
parentdev-python/pypiserver: Bump to 2.3.2 (diff)
downloadgentoo-f8e04db05c4f80921c8b4a84c1bb722befb1a80d.tar.gz
gentoo-f8e04db05c4f80921c8b4a84c1bb722befb1a80d.tar.bz2
gentoo-f8e04db05c4f80921c8b4a84c1bb722befb1a80d.zip
dev-python/tqdm: Bump to 4.67.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.67.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index f5b9b494cad4..c3c25032177a 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.67.0.tar.gz 169739 BLAKE2B e596b4a8e1c9af1b21f55dbf8f96ae716d4a28700fdeeddd7073f0ee73429e745d3e69824f9d53d258e646fdc84228c7407a432fbf00a6fd5651eb3fe62136fb SHA512 87c9f233eb28ff1570fc8b9a5a55c19b116b8dd451d82f1bfb14ca8bf8a2c3135fe9b788476c301ca169ef2c32099945178907feebdb4129eac2558d205e5715
+DIST tqdm-4.67.1.tar.gz 169737 BLAKE2B 9591a60570084670cd8e69b44455a374ef7dd91077c1b598f474f261bd0baef6a37b91214d0c9303fb5d04eb6537bebd4d1ba9ed99a8aa496dbca8ec2811c7d0 SHA512 f97d35ff73c9ba92c6cbfc2834cdedcdad2ec1d757ed40220b29d8c8863b197d8d00533e7f2a41589a9f68de1d053cc9715cc8b597759a3dcf96fec192edf4e3
diff --git a/dev-python/tqdm/tqdm-4.67.1.ebuild b/dev-python/tqdm/tqdm-4.67.1.ebuild
new file mode 100644
index 000000000000..bc14c7f690aa
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.67.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-asyncio-0.24[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}