summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-05 09:16:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-05 10:27:22 +0200
commit7665ef6c669b69bd1be827c357255c8d376ba404 (patch)
tree7be2becb990cb444aada920f7ba663f2059cbf62 /dev-python/transitions/transitions-0.8.10.ebuild
parentdev-python/pylast: Bump to 4.3.0 (diff)
downloadgentoo-7665ef6c669b69bd1be827c357255c8d376ba404.tar.gz
gentoo-7665ef6c669b69bd1be827c357255c8d376ba404.tar.bz2
gentoo-7665ef6c669b69bd1be827c357255c8d376ba404.zip
dev-python/transitions: Bump to 0.8.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/transitions/transitions-0.8.10.ebuild')
-rw-r--r--dev-python/transitions/transitions-0.8.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/transitions/transitions-0.8.10.ebuild b/dev-python/transitions/transitions-0.8.10.ebuild
new file mode 100644
index 000000000000..b0e276abfbff
--- /dev/null
+++ b/dev-python/transitions/transitions-0.8.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ || (
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ use examples && dodoc examples/*.ipynb
+}