summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-26 15:30:38 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-26 17:13:36 -0800
commit14240f9670e45f722750d2ff39e3c8ddd10199e8 (patch)
tree5a9af6e5f79dc72756ca8e9eb8f731f24025b33b /dev-python/u-msgpack/u-msgpack-2.5.2.ebuild
parentdev-python/webencodings: Revbump, add py37 (diff)
downloadgentoo-14240f9670e45f722750d2ff39e3c8ddd10199e8.tar.gz
gentoo-14240f9670e45f722750d2ff39e3c8ddd10199e8.tar.bz2
gentoo-14240f9670e45f722750d2ff39e3c8ddd10199e8.zip
dev-python/u-msgpack: Version bump to 2.5.2, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/u-msgpack/u-msgpack-2.5.2.ebuild')
-rw-r--r--dev-python/u-msgpack/u-msgpack-2.5.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/u-msgpack/u-msgpack-2.5.2.ebuild b/dev-python/u-msgpack/u-msgpack-2.5.2.ebuild
new file mode 100644
index 000000000000..c128ce847af0
--- /dev/null
+++ b/dev-python/u-msgpack/u-msgpack-2.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="https://github.com/vsergeev/u-msgpack-python https://pypi.org/project/u-msgpack-python/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest