summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-06-10 10:12:47 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-06-10 10:18:05 +0200
commite7b8d95aaecd81dc72d71f7275da34759d5fa715 (patch)
treec75ee9acb186b5069e693b8175d9fcf41c204e8b /dev-python/ubelt
parentdev-python/xxhash: enable py3.13 (diff)
downloadgentoo-e7b8d95aaecd81dc72d71f7275da34759d5fa715.tar.gz
gentoo-e7b8d95aaecd81dc72d71f7275da34759d5fa715.tar.bz2
gentoo-e7b8d95aaecd81dc72d71f7275da34759d5fa715.zip
dev-python/ubelt: add 1.3.6
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-python/ubelt')
-rw-r--r--dev-python/ubelt/Manifest1
-rw-r--r--dev-python/ubelt/ubelt-1.3.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/ubelt/Manifest b/dev-python/ubelt/Manifest
index 3867c1579418..c0e2bb4ecd1a 100644
--- a/dev-python/ubelt/Manifest
+++ b/dev-python/ubelt/Manifest
@@ -1 +1,2 @@
DIST ubelt-1.3.5.gh.tar.gz 361497 BLAKE2B 68887d1147faf44cc6c0b62441362c903d20bf141921c62122bbd846fb5d886f8bc4d7012262e2a146670996fc7c39238534f9d9e768f073d279f6234ea23fd8 SHA512 bf54345a1dd8cd737525b91050e587e86fbde29fef7ae787dba8c5dae675ee763e193a460f567d89229592c43c780a65091ffcab008383e06dd1318c7a9f3dd3
+DIST ubelt-1.3.6.gh.tar.gz 370002 BLAKE2B 1c3674ada7d2e0b9db7cbd28da50e453d6a56a81f8f874d4f791f6d41b5b8427d3dec84aa4c0cb283f6a38f5e413539193c4120a18b87442fb80507720f0b5c8 SHA512 bde288aca46bb62ac189a7ee2f3fc0771a766097b0ffca954ac90d8edd8ca156bad87c07163e812e99929ad8032b77d12cbfa984145cb7bc053fa4ab30d39a4a
diff --git a/dev-python/ubelt/ubelt-1.3.6.ebuild b/dev-python/ubelt/ubelt-1.3.6.ebuild
new file mode 100644
index 000000000000..4990d2a18424
--- /dev/null
+++ b/dev-python/ubelt/ubelt-1.3.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="
+ https://github.com/Erotemic/ubelt/
+ https://pypi.org/project/ubelt/
+"
+SRC_URI="
+ https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ dev-python/xdoctest[${PYTHON_USEDEP}]
+ >=dev-python/xxhash-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_editable_modules.py::test_import_of_editable_install
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)